Problem

May 9, 2012 at 1:33 PM

I've bumped into some problem. Perhaps it's just something I missed in the instructions, but I've tried to follow them almost to the letter. I always get stuck on the settings page (or when I press the "New from template" button). SharePoint throws this error:

System.IO.FileNotFoundException: <nativehr>0x80070002</nativehr><nativestack></nativestack>There is no Web named "/sites/templatehub/".

I've created a site collection called templatehub, with libraries in it with the title field and everything. I've also run the definehub script as described. What is the issue? Thanks!

May 10, 2012 at 10:23 AM

The "New from template" or settings page will not find your template hub site if you forgot the trailing /'s or don't use full urls when running definehub.ps1.
(we'll look into fixing that and making it more forgiving about url formatting...)
.\definehub.ps1 "http://yourteamsite.com/" "http://yourtemplatehub.com/sites/templatehub/"

Since standard SharePoint security is used, all users that are supposed to use it also needs read access to your template hub site.
(in other words, give "all authenticated users" at least read/visitor access to the site that hosts your templates for a quick fix :) )

I will try to write more of the documentation next week, including the content type handling, as well as update the source from our internals, since we added some new features (event receivers when creating new document libraries for getting published content types attached automatically...)

PS: I'm on vacation starting today. Will be back tuesday, so I won't be able to follow up until then if you still have problems...

May 10, 2012 at 11:06 AM

Alright, I solved the problem. My bad, I just created a template library on the root site, when I should have made a new site and created the library there. I'm now however stuck again. This time it's almost the same thing but that the list doesn't exist.

The page you selected contains a list that does not exist. It may have been deleted by another user.<nativehr>0x81020026</nativehr><nativestack></nativestack>

I've tried messing around with permissions and so on, but nothing seems to fix it.

May 30, 2012 at 4:08 PM
Edited May 30, 2012 at 4:11 PM

We located a bug when using managed paths for the site that stores the templates, so it it is recommended that you create a document library on a subsite instead of under the managed "sites" path. I haven't tried using a library on the root site, so you might have found a bug when there is no "subsite" url to process as well. I'll check it out when Dell returns my computer, whenever that will be (*sic*)...

we use http://site/subsite/TemplateLibrary here with success (we have a resource site for all common things, so our url would be http://resource/TemplateHub/Templates/, where TemplateHub is a subsite using the blank template, and Templates would be our document library for hosting the templates. DefineHub then gets http://resource/TemplateHub/ as its templatehub parameter).

Will this get your stuff working?

I'll check out our Url-parsing stuff as soon as possible.