Deployed solution giving error file not found

Aug 22, 2012 at 7:39 PM
Hi I am able to deploy template connector wsp solution on web application solution is deployed sucessfully but in site collection available under this web all , site collection feature is not showing this feature to activate soi activated it using ps shell cmd after actvation in docu libarary showing option. Select fromtemplete hub but gives me error " file not found " and sharepoint error page may I missing something ? In doc lib settings I m able to view select temple connector doc lib and to select template hub doc library.. I am using same web application in which I defined template hub is content type is mandatory for template type hub for ths solution is anything missing here??
Coordinator
Aug 28, 2012 at 12:45 PM

Did you deploy using the provided powershell script?
And you followed the instructions under the documentation section for Getting Started for Administrators?
http://templatehub.codeplex.com/wikipage?title=Getting%20started%20for%20administrators&referringTitle=Installation%20instructions

Using the same web application should not be an issue, but we are aware of issues using managed paths.

content type hub is only mandatory if you want to use the content type distribution services and the metadata promotion/demotion features that SharePoint offers.

Jan 15, 2013 at 3:06 PM

Hi, I am also experiencing the same.

I deployed the solution using powershell as admin. I did have to activate the feature using powershell also, as was not visible within the Site Collection Feature gallery.

When I select the  'New from template' option on a subsequent library, I do get the selector for the template gallery document library. After that though, I get an 'Unexpected Error' with a Correlation ID.

Not sure where I go from here, any suggestions?

Coordinator
Jan 16, 2013 at 11:24 AM

In the updated solution, the feature is visible in the Site Collection Gallery. Can you upgrade to the latest version and see if that resolves your problems?

Jan 16, 2013 at 11:32 AM
Edited Jan 16, 2013 at 12:14 PM



Hi,

I only download the files yesterday from Codeplex/Templatehub – they appear to be the most up to date?

 I'm tried retracing all my actions against the supplied instructions, and nothing seems out of place. I am getting an error, when looking into the log, its saying no site exists. The URL is my templatehub site, but with a "/" infront of it. Nothing in PS was set with this, so I am at a loss.

Do you have details on how to best retract/uninstall the solution? When I attempt to uninstall, I get the following:

 

PS C:\Users\ServiceAccount> Uninstall-SPSolution -
TemplateLibraryConnector.wsp -WebApplication https://webapp Uninstall-SPSolution : A parameter cannot be found that matches parameter name
'TemplateLibraryConnector'.
At line:1 char:47
+ Uninstall-SPSolution -TemplateLibraryConnector <<<< .wsp -WebApplication http
s://webapp    + CategoryInfo          : InvalidArgument: (:) [Uninstall-SPSolution], Par
   ameterBindingException
    + FullyQualifiedErrorId : NamedParameterNotFound,Microsoft.SharePoint.Powe
   rShell.SPCmdletUninstallSolution

(Webapp & Service Accountmodified above for obvious reasons)

 

Regards

Kevin

 




Jan 16, 2013 at 12:36 PM

I've retracted the solution via CA, and will try again soon to install the functionality again. I'll update you with the outcome! Fingers crossed :)

Jan 16, 2013 at 7:02 PM
Edited Jan 16, 2013 at 7:04 PM

Hi oyeism,

When I installed the TemplateHub the feature was also invisible and I also activated it through PowerShell. And it did worked fine for me. Invisible feature is not the problem in your environment that its not working.

And if you are using different WebApplications for template hub than content site then it could possibly another issue. In that case when content site tries to access the documents from templatehub' site it uses the user i.e. "Application Pool Id" to access the content database of content type hub. (incase your application pool ids are different for both the web-apps)

It could be fixed either by using the same application pool ids in both the web-applications or by giving permissions to application pool id over content site's database of template hub' web-application. 

Regards,

faisal

Coordinator
Jan 17, 2013 at 1:57 PM
Edited Jan 17, 2013 at 2:10 PM

Faisal, thanks for reminding me about the Application pools :)

I knew that, but forgot to make a note of it in the doc. The solution uses the server side Object model, so in order to avoid database access issues, you need to use the same Application pool account, or give the application pool accounts for the content sites access to the templatehub database.

I will update the wiki pages...

Edit: Requirements Wiki page is now updated with the Application pool account requirement. Thanks :)

--

Kjetil